Help Excel Somme Prod conditionnel

C'est ainsi que commença la déchéance des forums Requiem & Wizard's Lair
Avatar de l’utilisateur
Ngold
Membre
Messages : 13219
Inscription : 14 Août 2005, 00:33
Contact :

Help Excel Somme Prod conditionnel

Messagepar Ngold » 24 Sep 2020, 17:27

Hello tous,

Google ne m'a pas donné ma réponse alors je tente ici.

Sur excel, j'ai 3 colonnes A, B, C.

J'aimerais faire la somme du produit case à case de B et C (un somme prod classique) mais seulement pour les lignes où la case de la colonne A a la valeur de la case D4.

Quelle est la formule à utiliser?

Merci d'avance !
Au début on voulait faire les 10 Commandements, mais on n'avait pas de pyramide. Alors on a voulu faire Autant en emporte le vent, mais on n'avait pas Clark Gabble. Alors on a filmé le chat

Avatar de l’utilisateur
meuhmeuh
Membre
Messages : 529
Inscription : 16 Nov 2011, 01:33
Localisation : Vietnam, 1972, ptain de guerre ...

Re: Help Excel Somme Prod conditionnel

Messagepar meuhmeuh » 24 Sep 2020, 17:36

ça serait pas un truc du genre : =SI(A1=$D$4;SOMMEPROD(B1:C1);) ? Sachant que la valeur si faux est 0 ici (mais à remplacer par ce que tu veux)

(ou alors j'ai mal compris l'énoncé)
"Dans la vie ,il ne faut jamais se laisser abattre"
J.F.K

Après le célèbre titre de C.François, la reprise Lilloise : "Begonia for ever"

BlackOnly
Membre
Messages : 56
Inscription : 27 Sep 2010, 21:57

Re: Help Excel Somme Prod conditionnel

Messagepar BlackOnly » 24 Sep 2020, 17:59

Un truc comme ça devrait fonctionner si j'ai bien compris ton explication :
=SOMMEPROD(--(A:A=$D$4);B:B;C:C)

Avatar de l’utilisateur
Glacius
Membre
Messages : 825
Inscription : 20 Mars 2006, 22:22
Localisation : Lyon

Re: Help Excel Somme Prod conditionnel

Messagepar Glacius » 24 Sep 2020, 17:59

Tu multiplies la colonne B par (colonne A = $D$4) :

=SOMMEPROD(B:B*(A:A=$D$4);C:C)

Avatar de l’utilisateur
Ngold
Membre
Messages : 13219
Inscription : 14 Août 2005, 00:33
Contact :

Re: Help Excel Somme Prod conditionnel

Messagepar Ngold » 24 Sep 2020, 19:34

J'ai du mal m'y prendre car rien n'a fonctionné...

ça m'embête mais je vais devoir faire par un calcul intermédiaire je crois
Au début on voulait faire les 10 Commandements, mais on n'avait pas de pyramide. Alors on a voulu faire Autant en emporte le vent, mais on n'avait pas Clark Gabble. Alors on a filmé le chat

Avatar de l’utilisateur
May
Membre
Messages : 10370
Inscription : 24 Jan 2009, 18:33

Re: Help Excel Somme Prod conditionnel

Messagepar May » 24 Sep 2020, 21:15

Les formules proposées doivent être les bonnes mais il faut les valider par ctrl+alt+entrer
And the stage is set for the greatest flying super-mutant zombie shark air battle the world has ever seen

Avatar de l’utilisateur
guivre1408
Membre
Messages : 14374
Inscription : 31 Déc 2005, 18:05
Localisation : colmar/tours
Contact :

Re: Help Excel Somme Prod conditionnel

Messagepar guivre1408 » 24 Sep 2020, 21:36

A priori c'est ca

=sommeprod((A2:Anbligne=D4)*(B2:Bnbligne)*(C2:Cnbligne))

Proof :

somme prod ez.JPG
somme prod ez.JPG (24.59 Kio) Consulté 247 fois


Je capte pas ce que les autres ont voulu faire avec des SI, pour moi sommeprod ca sert justement dans les cas comme ca, sinon c'est juste une multiplication des totaux de lignes

Quand je suis en galère avec un somme prod, je m'en sors toujours avec les exemples à la con de ce site

http://www.bernardcordier.com/excel_sommeprod.htm
Even if you play mind funeral early, you are still going to get rid of four lands that your opponent might need. If not the chance of hitting good spells that alter the game state is worth it as well, IMO.

Avatar de l’utilisateur
Ngold
Membre
Messages : 13219
Inscription : 14 Août 2005, 00:33
Contact :

Re: Help Excel Somme Prod conditionnel

Messagepar Ngold » 25 Sep 2020, 09:44

Nickel merci Guivre !
Au début on voulait faire les 10 Commandements, mais on n'avait pas de pyramide. Alors on a voulu faire Autant en emporte le vent, mais on n'avait pas Clark Gabble. Alors on a filmé le chat

Yoman
Membre
Messages : 4117
Inscription : 14 Août 2005, 07:46

Re: Help Excel Somme Prod conditionnel

Messagepar Yoman » 25 Sep 2020, 10:12

phpBB [media]


Revenir vers « Mène-à-Rien »

Qui est en ligne ?

Utilisateurs parcourant ce forum : guivre1408, Joey, mattamort, Nokiou, Talisker, tiyan, Zoorp et 6 invités